Degraded performance and latency due to upstream provider issues

Incident Report for Castle

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 04:56 UTC

Identified

We are observing an elevated number of errors and slightly higher latency than normal due to upstream provider issues in AWS US-EAST-1 (us-east-1a). We are continuing to monitor the situation.
https://health.aws.amazon.com/health/status
Posted May 08, 2026 - 04:31 UTC
This incident affects: Risk and Filter APIs, Log API, and Legacy APIs.