Potential service disruption
Incident Report for Castle
Resolved
Most of the AWS systems are working already and the few that are not are recovering fast.
Posted Dec 07, 2021 - 22:35 UTC
Monitoring
We are keeping this incident open while we wait for AWS systems to recover.
Posted Dec 07, 2021 - 18:02 UTC
Investigating
Our hosting provider AWS is currently experiencing issues, however, it is not affecting the Castle services at the moment. All Castle services are fully functional, and we're actively monitoring the situation.

Please see AWS' status page for more information: https://status.aws.amazon.com
Posted Dec 07, 2021 - 16:37 UTC